On Sat, Nov 22, 2025 at 10:17:17AM -0800, Eric Biggers wrote: > On Tue, Nov 18, 2025 at 07:21:47AM +0100, Christoph Hellwig wrote: > > diff --git a/fs/crypto/inline_crypt.c b/fs/crypto/inline_crypt.c > > index 1773dd7ea7cf..aba830e0827d 100644 > > --- a/fs/crypto/inline_crypt.c > > +++ b/fs/crypto/inline_crypt.c > > @@ -361,7 +361,7 @@ EXPORT_SYMBOL_GPL(fscrypt_set_bio_crypt_ctx_bh); > > * fscrypt_mergeable_bio() - test whether data can be added to a bio > > * @bio: the bio being built up > > * @inode: the inode for the next part of the I/O > > - * @next_lblk: the next file logical block number in the I/O > > + * @pos: the next file logical offset (in bytes) in the I/O > > In comments, maybe call it a "file position" instead of "file logical > offset" to match the variable name?
Doing a quick grep, "file offset" seems to be a bit more than twice as common as "file position" in the kernel. Logical offset, even without file is barely used. So I think "file offset' might be best here, but if you prefer "file position" I can switch to that as well.
