On Tue, Apr 24, 2007 at 12:11:19PM +0100, Christoph Hellwig wrote:
> On Tue, Apr 24, 2007 at 01:05:49PM +0200, Nick Piggin wrote:
> > On Tue, Apr 24, 2007 at 11:46:47AM +0100, Christoph Hellwig wrote:
> > > > +       page = __grab_cache_page(mapping, index);
> > > 
> > > btw, __grab_cache_page should probably get a more descriptive and
> > > non-__-prefixed name now that it's used all over the place.
> > 
> > Agreed. Suggestions? ;)
> 
> find_or_create_cache_page given that's it's like find_or_create_page +
> add_to_page_cache?

find_or_create_page adds to page cache as well, though :P

All those random little slightly different allocators scattered over
filemap.c are a bit annoying. Basically I think it would be better
to have a single variant that takes gfp_mask of both the pagecache
page, and the radix-tree insertion. Then serveral things can be
converted to use it.

I was going to try doing that after this patchset. Or do you think it
would be better to get the __grab_cache_page name right in the
first place?
-
To unsubscribe from this list: send the line "unsubscribe linux-fsdevel" in
the body of a message to [EMAIL PROTECTED]
More majordomo info at  http://vger.kernel.org/majordomo-info.html

Reply via email to