Hello Gustavo,

I appreciate you working on keeping up the kernel and maintaining some of the older feature areas like AX.25, Netrom, etc. Other than auditing your code changes, can you tell me what you're changing? I've been attempting to find who / where does regression tests for the Linus kernel to potentially ADD test suites for this area. In the recent past, we have seen a lot of toxicity creep into the kernel because no one is testing their changes and backing out this toxic code out of released Linux distributions takes a VERY long time.

I'm willing to try and help here but I really would like to follow some team's guidelines of how they would like tests to be created, supported, etc. Be it in VMs, containers, specific automation languages, etc.

--David
KI6ZHD




On 10/26/2017 10:50 PM, Gustavo A. R. Silva wrote:
The aim of this patchset is firstly to refactor code in nr_route.c in order to 
make it
easier to read and maintain and, secondly, to mark some expected switch 
fall-throughs
in preparation to enabling -Wimplicit-fallthrough.

I have to mention that I did not implement any unit test.
If someone has any suggestions on how I could test this piece of code
it'd be greatly appreciated.

Thanks

Changes in v2:
  - Make use of the swap macro and remove inline keyword as suggested by
    Walter Harms and Kevin Dawson.

Changes in v3:
  - Update subject for both patches.
  - Add this cover letter as suggested by David Miller.

Gustavo A. R. Silva (2):
   net: netrom: nr_route: refactor code in nr_add_node
   net: netrom: nr_route: mark expected switch fall-throughs

  net/netrom/nr_route.c | 62 ++++++++++++++++-----------------------------------
  1 file changed, 19 insertions(+), 43 deletions(-)


--
To unsubscribe from this list: send the line "unsubscribe linux-hams" in
the body of a message to majord...@vger.kernel.org
More majordomo info at  http://vger.kernel.org/majordomo-info.html

Reply via email to