Linux-Hardware Digest #985, Volume #9            Sat, 10 Apr 99 14:13:29 EDT

  ISDN / BT Speedway Problem (HiSax/Fritz) (Simon Griffiths)
  Difficulty with SB 64 PCI and kernel 2.2.5 (Dick Repasky)
  Re: Sparc (Frank Sweetser)
  Diamond SpeedStar A50, 8 meg _AGP_, SiS 6326 based ("Gene Heskett")
  Re: Sis6326 and X-windows ("steven_ng")
  Buslogic Flashpoint driver options ("Tom Barnes-Lawrence")
  PCI memory mapped register (jeff)
  Re: X terminal? (Chris Evich)
  Re: [Fwd: Source Code To Windows 98 (programmer humor) (fwd)] (Ben Pfaff)
  Re: Hardware products to control things in homes ("Gene Heskett")
  Re: Help: Creative Vibra Pnp (patrick wong)
  Slow Tx on SMC1211TX (Hugh Fader)
  Re: Difficulty with SB 64 PCI and kernel 2.2.5 (CIMEBOAT)


From: Simon Griffiths <[EMAIL PROTECTED]>
Crossposted-To: comp.os.linux.networking
Subject: ISDN / BT Speedway Problem (HiSax/Fritz)
Date: Sat, 10 Apr 1999 14:47:07 +0100


I've currently got a 2.2.5 kernel with modular support for IDSN/HiSax
and a BT Speedway PCI card. All looks fine....

but I get :

Apr 10 14:10:23 localhost kernel: ISDN subsystem Rev:
1.55/1.47/1.55/1.33/none/1.2 loaded
Apr 10 14:10:24 localhost kernel: HiSax: Driver for Siemens chip set
ISDN cards
Apr 10 14:10:24 localhost kernel: HiSax: Version 2.8
Apr 10 14:10:24 localhost kernel: HiSax: Revisions 2.18/2.7/2.5/2.13/2.7
Apr 10 14:10:24 localhost kernel: HiSax: Card 1 Protocol EDSS1 Id=Fritz
Apr 10 14:10:24 localhost kernel: HiSax: AVM driver Rev. 2.7
Apr 10 14:10:24 localhost kernel: AVM A1: Byte at 7c00 is ff
Apr 10 14:10:24 localhost kernel: AVM A1: Byte at 7c03 is ff
Apr 10 14:10:24 localhost kernel: AVM A1: Byte at 7c02 is ff
Apr 10 14:10:24 localhost kernel: AVM A1: Byte at 7c00 is ff
Apr 10 14:10:24 localhost kernel: HiSax: AVM A1 config irq:9 cfg:0x7C00
Apr 10 14:10:24 localhost kernel: HiSax: isac:0x7800/0x7400
Apr 10 14:10:24 localhost kernel: HiSax: hscx A:0x6800/0x6400  hscx
Apr 10 14:10:24 localhost kernel: AVM A1: ISAC version : 2085 V2.3
Apr 10 14:10:24 localhost kernel: AVM A1: HSCX version A: ???  B: ???
Apr 10 14:10:24 localhost kernel: AVM A1: wrong HSCX versions check IO
Apr 10 14:10:24 localhost kernel: HiSax: Card AVM A1 not installed !
Apr 10 14:10:24 localhost kernel: ISDN-subsystem unloaded

everytime I try to load the HiSax module with...

modprobe -v hisax io=0x6400 irq=9 protocol=2 type=5 id=Fritz

The io and irq settings are what NT4 thinks they are, and the card works
great in NT !

also 'insmod isdn' loads fine too !

Does anyone have any ideas ?

Thanks in advance,


From: [EMAIL PROTECTED] (Dick Repasky)
Subject: Difficulty with SB 64 PCI and kernel 2.2.5
Date: 10 Apr 1999 13:49:30 GMT

I am unable to get my SB 64 PCI card to work under kernel 2.2.5.  The card
matches the Ensonic 1370 (cat /proc/bus/pci reports match expectations
from the kernel configuration help button).  I get the following messages
on bootup or from dmesg, independently of whether sound is compiled in
or loaded as a module:

   es1370: version v0.19 time 12:19:32 Apr  3 1999
   es1370: found adapter at io 0x6200 irq 9
   es1370: features: joystick off, line in, mic impedance 0

So far as I can determine, irq 9 and io 0x6200 conflict with
nothing. However, if I cat /dev/sndstat I get the following:

   cat: /dev/sndstat: Operation not supported by device

/dev/sndstat is: 

   crw-rw-rw-   1 root     sys       14,   6 May  5  1998 /dev/sndstat  
I stopped here, because "cat /dev/sndcat" is a test prescribed in the
Sound-HOWTO, and it clearly fails.  

I know that PnP shouldn't make a difference because the card is PCI,
but I got the same results with PnP enabled in both the kernel and the
bios, PnP enabled in bios but not kernel, and PnP disabled in both
kernel and bios.

Something that I would like to try, but cannot, is to check out the
IRQ and io address from DOS.  I can't because the card requires either
windows 95 or windows NT, and I have neither.  (Just dos and windows 3.1).

Details of hardware:
  cpu: pentium 133
  motherboard: magitronic  (i.e., Brand X)
  scsi:  buslogic bt-946
  video: ATI charger
  ethernet: E2000 (ISA)

These components work well together under 2.0.* kernel series and also
under 2.2.5.

Otherwise the system is stock Red Hat 5.2 with kernel 2.2.5 source tree
taken from  I've not tried kernel 2.2.[1-4].

Any suggestions?



P.S. My experience with this sound card under kernel 2.0.36 was worse
than the experience reported above.  Using sndconfig hung the machine.


Remove the underscore from my e-mail address to reply by mail.


From: Frank Sweetser <[EMAIL PROTECTED]>
Subject: Re: Sparc
Date: 10 Apr 1999 10:57:49 -0400


> hi,
>   I want to set up a Sparc/Linux cluster.. How do I configure Sparc Classic/
> Sparc 5/Sparc 10 so that it would not attempt to detect keyboard/mouse upon
> power-on ?

if you unplug the monitory and keyboard, and plug a VT into the first
serial port, the detection will fail, and it'll switch over to using a
serial console.

Frank Sweetser rasmusin at fsweetser at  | PGP key available RedHat 5.2 kernel 2.2.5        i586 | at public servers
I don't know if it's what you want, but it's what you get.  :-)
             -- Larry Wall in <[EMAIL PROTECTED]>


Date: 10 Apr 99 09:58:01 -0500
From: "Gene Heskett" <[EMAIL PROTECTED]>
Subject: Diamond SpeedStar A50, 8 meg _AGP_, SiS 6326 based

Newbie here, trying to breath life into a new box with a TYAN S1590S
mobo, and a 400 mhz AMD K6-2/3dNow and 64 megs in it.

I'm told that XFree86- supports the video card in the subject line.

Can someone with more knowledge than I give me the path to the latest
patched binary rpm for the i386?  So far, all I've found is source, and
some of it is too big for sneakernet's floppies...

I've got a NIC I could put in it, but my _real_ hard drive is still on a
cart at some airport, and the startup drive is full without any
networking installed.

I get the impression that because this _AGP_ card shares system ram, and
system ram is all grabbed by ramdisks at bootup that this may be the
reason startx won't, it exits with a squawk about only 64k of video ram.

Is there something that needs to be changed in the bootup, or will the
new XFree86 fix this all by itself?

I also have some Adaptec AVA 1502 scsi cards.  They're the 'throwaways'
that come with an internal scsi Zip drive, and that we never used when
adding them to our Amiga's or the Dubner 30k CG.

Without a drive on the card, probing for an AVA 152x comes up empty,
with host not found type msgs.

Is there any chance they can be used?  If so, where can that driver be

Cheers, Gene
  Gene Heskett, CET, UHK       |Amiga A2k Zeus040 50 megs fast/2 megs chip
    Ch. Eng. @ WDTV-5          |A2091,GuruRom,1g Seagate,CDROM,Multiface III
<[EMAIL PROTECTED]>  or  |Buddha + 4 gig WDC drive, 525 meg tape
<[EMAIL PROTECTED]>|Stylus Pro, EnPrint, Picasso-II, 17" vga
         RC5-Moo! 22kkeys/sec isn't much, but it all helps


From: "steven_ng" <[EMAIL PROTECTED]>
Crossposted-To: hk.comp.os.linux,
Subject: Re: Sis6326 and X-windows
Date: Sat, 10 Apr 1999 22:00:18 +0800

Yes I have same problem ?

Kevin Tse g峹 <[EMAIL PROTECTED]>...
>I'm using Redhat 5.2, display card Sis6326 AGP.
>after the installation i was not able to start x windows.
>say memory not enough, i was able to start in a very low
>resolution, 3?? x 3?? something.
>i d/l XFree86, after install and config,
>i can start x windows but only see the mouse cursor in a
>black background.  the mouse can move and change to pointer when
>it touch something.
>how can i fix the x windows??
>one more thing, after the new XFree86 installed, the orginial
>very nice red hat desktop is removed.  how to restore the very
>nice red hat desktop??
>I'm completely new to linux, please help!
>kindly reply thru' email! Thanks!


From: "Tom Barnes-Lawrence" <[EMAIL PROTECTED]>
Subject: Buslogic Flashpoint driver options
Date: Sat, 10 Apr 1999 17:26:45 +0100

    I've been having trouble using my Flashpoint LW SCSI card with a WangDat
3200 DAT drive and Linux. Most of the trouble isn't Linux, but I'm wondering
about driver options.
    When the system boots, if the DAT drive is selected for BIOS scan, the
card sits there for about 5 minutes trying to scan it. Sometimes it decides
its a second CD recorder, other times it decides its not there. If the
drives selected to not BIOS scan, it decides it isnt there too. At other
points in the SCSI BIOS setup, the card sees it fine.
    When the Linux driver starts up, if the drive isn't mentioned in the
BIOS scan list, Linux doesn't detect it.
    No, it isn't an ID problem, it's on ID6, not sharing with anything else.
Everything else confirms this. Linux even sees there's something on ID6
though it doesn't mention the DAT.
    If I do [echo "scsi add-single-device 0 0 6 0">/proc/scsi/scsi] or
whatever it is, *and* there's a tape in the drive, Linux notices it. From
then, I can use the drive quite acceptably (I haven't tested it that
extensively, but I've played music off it and stuck tar archives onto it,
and written text onto it, it seems OK).
    If I boot into windows with command prompt mode, and the SCSI drivers,
*DOS* manages to see it! I think that's letting the side down...
    Oh, and I did try upgrading the BIOS as it was several revs behind.
After making it unbootable, sending the card back to Mylex, and getting the
card back with new latest BIOS installed, the card worked but the scan
problem still wasn't solved by the new BIOS.
    Even if I can get Linux to see it in the way mentioned, I don't think
that's a satisfactory way of doing it, so can anyone suggest some hidden
driver options that get Linux to look a bit harder for the drive? Perhaps in
the latest driver version? I looked at the source in my current (2.0.34)
kernel and nothing seemed appropriate.
    I already posted a similar question to comp.periphs.scsi, who were quite
helpful but that was when they suggested I upgrade the BIOS. It does seem
more a Linux related thing.
Tom Barnes-Lawrence (aka Tomble the Bod)
Kindly remove eggs and spam from email address
in order to email me.


From: jeff <[EMAIL PROTECTED]>
Subject: PCI memory mapped register
Date: Sat, 10 Apr 1999 10:02:38 -0500

does anyone know where I can find an example source code for memory
mapping of PCI board device registers.

thanks a bunch!


From: Chris Evich <[EMAIL PROTECTED]>
Crossposted-To: comp.os.linux.x
Subject: Re: X terminal?
Date: Fri, 09 Apr 1999 14:16:37 +0000

So they do exist then.  What company makes them? Can I find them on the
net anywhere?

> In article <[EMAIL PROTECTED]>,
>   "Chris Evich (P0d)" <[EMAIL PROTECTED]> wrote:
> > Does there exist a good cheap(?) X windows terminal/console thingie you
> > can buy and plug into your network for running remote x-displays?  Or is
> > it cheaper to get a shitty pentium and do it that way?
> You might be able to find a company that is unloading some X terminals;
> but a Pentium will do a fine job.  Just configure X and then put
> X -bpp <whatever> -query <host>
> into your inittab.  Must be running xdm, wdm, or whatever on <host>
> Mark
> -----------== Posted via Deja News, The Discussion Network ==----------
>       Search, Read, Discuss, or Start Your Own


From: Ben Pfaff <[EMAIL PROTECTED]>
Subject: Re: [Fwd: Source Code To Windows 98 (programmer humor) (fwd)]
Date: 10 Apr 1999 13:13:09 -0400

Martin Ambuhl <[EMAIL PROTECTED]> writes:

   Kaz Kylheku wrote:
   > On Fri, 09 Apr 1999 16:30:32 -0700, Nick Ambrose <[EMAIL PROTECTED]> wrote:
   > >
   > >First, I removed alt.os.linux from the posting list.
   > >The compiler is (I think) required  to emit a diagnostic if you use void main().
   > >You are no longer writing C++.
   > YOu are no longer writing C or C++. And the compiler is permitted to make
   > things fly out of your nose in addition to emiting a diagnostic. It can also
   > produce an executable that brings up a game of nethack.  :)

   Sure you can still be writing C or C++, but only for a non-hosted

No, actually I think that's wrong.  A vendor is allowed to make any
extensions they want that don't change the behavior of strictly
conforming programs.  The presence of a clause in the standard saying
that there aren't any startup requirements for non-hosted
implementations doesn't change that; MS C *does* provide all the
functions and startup behavior of a hosted implementation, or at least
it did the last time I used it, more than a few years ago admittedly.

   Isn't it nice that MS finally admitted that
   virus-with-mouse-support is not an operating system?

'Twould be nice.
(supporter of the campaign for grumpiness where grumpiness is due in c.l.c)

Please: do not email me copies of your posts to comp.lang.c
        do not ask me C questions via email; post them instead


Date: 10 Apr 99 10:58:46 -0500
From: "Gene Heskett" <[EMAIL PROTECTED]>
Subject: Re: Hardware products to control things in homes

Gene Heskett sends Greetings to Ourcatalog ;

Spam is spam, I don't care what color you paint the damned can.  I'm
doing *all* this, and have been *doing* all this for years with an Amiga
and x10 stuff.  Preaching to the choir is not gonna generate any sales

Now go away, way away.  And stay there.

>Imagine controlling any appliance, home lighting, or audio/stereo/video

Cheers, Gene
  Gene Heskett, CET, UHK       |Amiga A2k Zeus040 50 megs fast/2 megs chip
    Ch. Eng. @ WDTV-5          |A2091,GuruRom,1g Seagate,CDROM,Multiface III
<[EMAIL PROTECTED]>  or  |Buddha + 4 gig WDC drive, 525 meg tape
<[EMAIL PROTECTED]>|Stylus Pro, EnPrint, Picasso-II, 17" vga
         RC5-Moo! 22kkeys/sec isn't much, but it all helps


From: patrick wong <[EMAIL PROTECTED]>
Subject: Re: Help: Creative Vibra Pnp
Date: Sat, 10 Apr 1999 09:50:47 -0700

Rogz wrote:

> I'm trying to get my Creative Vibra PnP (ISA) Soundcard to work in
> Linux. I've compiled the 2.2.2-kernel with the following modules:
>     <M> OSS sound modules
>     <M> 100% Sound Blaster compatibles (SB16/32/64, ESS, Jazz16) support
>     <M> Generic OPL2/OPL3 FM synthesizer support
>     <M> SoftOSS software wave table engine
> When running pnpdump I come up with the following configuration
> (comments stripped):
>     (READPORT 0x020b)
>     (IDENTIFY *)
>     (VERBOSITY 2)
>     (CONFIGURE CTL0070/-1 (LD 0
>     (INT 0 (IRQ 5 (MODE +E)))
>     (DMA 0 (CHANNEL 1))
>     (DMA 1 (CHANNEL 5))
>     (IO 0 (SIZE 16) (BASE 0x0220))
>     (IO 1 (SIZE 2) (BASE 0x0330))
>     (IO 2 (SIZE 4) (BASE 0x0388))
>     (ACT Y)
>     ))
> These values are ok, according to Win95 where the card works.
> If i run isapnp /etc/isapnp.conf I get the following:
>     lspci not found, so PCI resource conflict not checked
>     Board 1 has Identity e5 ff ff ff ff 70 00 8c 0e:  CTL0070 Serial No
> -1 [checksum e5]
>     CTL0070/-1[0]{Audio               }: Ports 0x220 0x330 0x388; IRQ5
> DMA1 DMA5 --- Enabled OK
> In /etc/modules I load the modules like this:
>     sound
>     soundcore
>     uart401 io=0x388
>     sb io=0x220 irq=5 dma=1 dma16=5 mpu_io=0x330
>     opl3 io=0x388
> If i do a 'cat /proc/sound' I end up with the following output:
>     OSS/Free:3.8s2++-971130
>     Load type: Driver loaded as a module
>     Kernel: Linux overlord 2.2.2 #5 Sat Apr 10 11:38:41 CEST 1999 i586
>     Config options: 0
>     Installed drivers:
>     Card config:
>     Audio devices:
>     0: Sound Blaster 16 (4.13) (DUPLEX)
>     Synth devices:
>     0: Yamaha OPL3
>     Midi devices:
>     0: Sound Blaster 16
>     Timers:
>     0: System clock
>     Mixers:
>     0: Sound Blaster
> According to '/proc/ioports' '/proc/dma' and '/proc/interrupts' the card
> is bound as per isapnp.conf
> What am I doing wrong since the driver isn't loaded?
> Thanks
>     Roger Svensson

Try setting dma16=3.  You might get an error message during boot up, but it
works anyway!!


From: Hugh Fader <[EMAIL PROTECTED]>
Crossposted-To: comp.os.linux.networking
Subject: Slow Tx on SMC1211TX
Date: Sat, 10 Apr 1999 11:30:51 -0400

I am having trouble with slow data transmission on my SMC1211TX 10/100
ethernet board and am hoping to get some help. I have a network of 1
Linux box and 2 Windows 95 boxes. The Linux box receives data at ~280
kbyte/sec but transmits at only 6 kbyte/sec. I am measuring this using
smbclient from Linux to the Win95 machines and also using ftp from the
Win95 machines to Linux. The Win95 machines seem to both transmit and
receive at an acceptable rate between each other using drag and drops of
files. Ifconfig shows no errors on the interface.

Here are the details of the Linux box:
rtl8139.c v 1.06 driver
Linux 2.0.36
Intel 233 MMX
Amptron TX3 motherboard
16 MB memory
STB Lightspeed video adaptor

All 3 machines are running SMC 1211TX boards. On Linux, I just switched
motherboards from a very old P75 which was experiencing Rx overruns but
which seemed to transmit and receive at a fast rate. This leads me to
believe there is something about the TX3 motherboard that is causing
this problem. This board has integrated graphics and sound which I have

I have tried many things to get to the bottom of this:
Set the boards to half-duplex.
Flashed most-recent bios.
Ran SMC diagnostics to verify the hardware.
Swapped the 1211 boards between machines.
Turned PnP off in the bios.
Re-installed Linux from scratch.
Tweaked some parameters in the driver.

I am now at a loss for what to try. Can anyone give me any clues as to
why the transmits would be so slow? How about other steps I could take
to troubleshoot this problem?

Thanks in advance.

Hugh Fader


Subject: Re: Difficulty with SB 64 PCI and kernel 2.2.5
Date: 10 Apr 1999 15:38:36 GMT

Have you tried sndconfig -- noprobe?



The service address, to which questions about the list itself and requests
to be added to or deleted from it should be directed, is:

    Internet: [EMAIL PROTECTED]

You can send mail to the entire list (and comp.os.linux.hardware) via:

    Internet: [EMAIL PROTECTED]

Linux may be obtained via one of these FTP sites:                                pub/Linux                              pub/linux                             pub/Linux

End of Linux-Hardware Digest

Reply via email to