>> I would appreciate if an unnecessary function call can be avoided here
>> so that the affected exception handling can become also a bit more efficient.
> Simpler code is easier to maintain.

There are different opinions available around the desired simplicity.

> See your patch, you didn't get it correctly at your first try.

I wonder myself about the circumstances on how my incomplete update suggestion
did happen.

> Also, this is not a hot path,

I'm curious if approaches around better exception handling can eventually become
a "hot topic".

> so I see it as a micro-optimization

I can agree to this view for this function implementation.

> also adding complexity.

There are the usual software development trade-offs.

> I don't favor that.

Thanks for your constructive feedback.

Is an identifier like "free_client" a bit nicer (according to the Linux coding
style recommendations) than the short jump label "err" in the discussed use 

To unsubscribe from this list: send the line "unsubscribe linux-i2c" in
the body of a message to majord...@vger.kernel.org
More majordomo info at  http://vger.kernel.org/majordomo-info.html

Reply via email to