Hi list

I am now in the process of upgrading my system to mandrake 7.0 from 6.0 
(by upgrading one package at a time).

I recently noticed a problem with apps that use the xaw toolkit on my
system (i.e. - gv, xfig, xfontsel). As far as I can remember - it started
after I upgraded XFree86 to 3.3.6 (without touching the xaw3d package,
although I have also upgraded it later, with no positive result)

The problem is that I can't select menu items: When I try to do that the
menu opens, but I can't select any item. I get no warning or error mesage
of any sort.

Any idea as for what might cause this? where can I get more information?
(needless to say I have tried deja.com et al.)

The libraries invloved:
[tzafrir@canada1 ~]$ rpm -qf `which xfontsel`
X11R6-contrib-3.3.2-8mdk
   (from mandrake 6.0)
[tzafrir@canada1 ~]$ ldd `which xfontsel`
        libXaw3d.so.6 => /usr/X11R6/lib/libXaw3d.so.6 (0x4000b000)
        libXmu.so.6 => /usr/X11R6/lib/libXmu.so.6 (0x40065000)
        libXt.so.6 => /usr/X11R6/lib/libXt.so.6 (0x40078000)
        libSM.so.6 => /usr/X11R6/lib/libSM.so.6 (0x400ca000)
        libICE.so.6 => /usr/X11R6/lib/libICE.so.6 (0x400d4000)
        libXext.so.6 => /usr/X11R6/lib/libXext.so.6 (0x400ec000)
        libX11.so.6 => /usr/X11R6/lib/libX11.so.6 (0x400fa000)
        libc.so.6 => /lib/libc.so.6 (0x401ac000)
        /lib/ld-linux.so.2 => /lib/ld-linux.so.2 (0x80000000)
[tzafrir@canada1 ~]$ rpm -qf /usr/X11R6/lib/libXaw3d.so.6
Xaw3d-1.5-4mdk
   (this one is from Mandrake 7.0. I had the problemalso with Xaw3d
    1.3.? from 6.0)
[tzafrir@canada1 ~]$ rpm -qf /usr/X11R6/lib/libXmu.so.6
XFree86-libs-3.3.6-4mdk
   (from mandrkae 7.0 . ditto for libXt, libSM, libICE, libXext, libX11)
[tzafrir@canada1 ~]$ rpm -qf /lib/libc.so.6
glibc-2.1.1-16mdk
   (from mandrake 6.1)
-- 
Tzafrir Cohen
mailto:[EMAIL PROTECTED]
http://www.technion.ac.il/~tzafrir


=================================================================
To unsubscribe, send mail to [EMAIL PROTECTED] with
the word "unsubscribe" in the message body, e.g., run the command
echo unsubscribe | mail [EMAIL PROTECTED]

Reply via email to