On 7/13/26 16:13, Alice Ryhl wrote:
On Mon, Jul 13, 2026 at 02:45:29PM +0800, Alvin Sun wrote:
Replace the `THIS_MODULE` static reference in the binder fops with
`this_module::<LocalModule>()`, consistent with the move of
`THIS_MODULE` into the `ModuleMetadata` trait.

Assisted-by: opencode:glm-5.2
Reviewed-by: Gary Guo <[email protected]>
Acked-by: Danilo Krummrich <[email protected]>
Signed-off-by: Alvin Sun <[email protected]>
Most other Rust Binder commits use 'rust_binder:' prefix rather than
'rust: binder:'.

I missed this prefix convention — thanks for catching it.

I'll fix it in the next revision, along with any other feedback that comes in.

Best regards,
Alvin


Alice

Reply via email to