Hello: This patch was applied to netdev/net-next.git (main) by Jakub Kicinski <[email protected]>:
On Wed, 22 Jul 2026 09:51:29 +0800 you wrote: > mmap() is documented to return MAP_FAILED on error, but tcp_mmap.c > compares the return value against (void *)-1 and (unsigned char *)-1. > > Replace these with the standard MAP_FAILED macro for better readability > and type safety. > > Signed-off-by: longlong yan <[email protected]> > > [...] Here is the summary with links: - selftests/net: use MAP_FAILED instead of (void *)-1 in tcp_mmap https://git.kernel.org/netdev/net-next/c/94cdc6a2c837 You are awesome, thank you! -- Deet-doot-dot, I am a bot. https://korg.docs.kernel.org/patchwork/pwbot.html

