On Fri, Apr 08, 2016 at 07:44:14PM +0200, Peter Zijlstra wrote:
> On Fri, Apr 08, 2016 at 02:55:22PM +0200, Frederic Weisbecker wrote:
> > > > @@ -4540,17 +4568,8 @@ static void cpu_load_update(struct rq *this_rq, 
> > > > unsigned long this_load,
> > > >  
> > > >                 /* scale is effectively 1 << i now, and >> i divides by 
> > > > scale */
> > > >  
> > > > -               old_load = this_rq->cpu_load[i];
> > > #ifdef CONFIG_NO_HZ_COMMON
> > > > -               old_load = decay_load_missed(old_load, pending_updates 
> > > > - 1, i);
> > > > -               if (tickless_load) {
> > > > -                       old_load -= decay_load_missed(tickless_load, 
> > > > pending_updates - 1, i);
> > > > -                       /*
> > > > -                        * old_load can never be a negative value 
> > > > because a
> > > > -                        * decayed tickless_load cannot be greater than 
> > > > the
> > > > -                        * original tickless_load.
> > > > -                        */
> > > > -                       old_load += tickless_load;
> > > > -               }
> > > #endif
> > 
> > Ah sure, if you prefer it that way, I can do that.
> 
> Yes please. I normally favour the thing you did, but here it makes
> tricky code that much harder to read.

So I tried and it warns about the unused variable tickless_load, so I
would need two scattered ifdeffery in the function:

@@ -4528,7 +4529,9 @@ decay_load_missed(unsigned long load, unsigned long 
missed_updates, int idx)
 static void cpu_load_update(struct rq *this_rq, unsigned long this_load,
                            unsigned long pending_updates)
 {
+#ifdef CONFIG_NO_HZ_COMMON
        unsigned long tickless_load = this_rq->cpu_load[0];
+#endif
        int i, scale;
 
        this_rq->nr_load_updates++;
@@ -4541,6 +4544,7 @@ static void cpu_load_update(struct rq *this_rq, unsigned 
long this_load,
                /* scale is effectively 1 << i now, and >> i divides by scale */
 
                old_load = this_rq->cpu_load[i];
+#ifdef CONFIG_NO_HZ_COMMON
                old_load = decay_load_missed(old_load, pending_updates - 1, i);
                if (tickless_load) {
                        old_load -= decay_load_missed(tickless_load, 
pending_updates - 1, i);
@@ -4551,6 +4555,7 @@ static void cpu_load_update(struct rq *this_rq, unsigned 
long this_load,
                         */
                        old_load += tickless_load;
                }
+#endif
                new_load = this_load;
                /*
                 * Round up the averaging division if load is increasing. This


Are you still sure you don't want the ifdeffed inline function?

Thanks.

Reply via email to