On 13/07/2016 17:47, Bandan Das wrote:
>>> I wanted to keep it the former way because "PT_PRESENT_MASK is equal to 
>>> VMX_EPT_READABLE_MASK"
>>> is an assumption all throughout. I wanted to use this section to catch 
>>> mismatches.
>>
>> I think there's no such assumption anymore, actually.  Can you double
>> check?  If there are any, that's where the BUILD_BUG_ON should be.
> 
> What I meant is how they are the same bit.  is_shadow_present_pte() is 
> probably one
> and another one is link_shadow_page() which already has a BUILD_BUG_ON().

You're right about link_shadow_page()!  We probably should change the
PT_PRESENT_MASK to shadow_present_mask there (and then readability in
the EPT execonly case is still provided by shadow_user_mask).

For is_shadow_present_pte() you have removed it in patch 1 though.

Paolo

Reply via email to