On 09/02/2016 02:37 PM, Arnd Bergmann wrote:
On Friday, September 2, 2016 2:27:21 PM CEST Laura Abbott wrote:

All warnings (new ones prefixed by >>):

   drivers/staging/android/ion/ion.c: In function 'ion_query_heaps':
drivers/staging/android/ion/ion.c:1181:3: warning: cast to pointer from integer 
of different size [-Wint-to-pointer-cast]
      (struct ion_heap_data __user *)query->heaps;
      ^


botching-up-ioctls.txt says:

  * Pointers are __u64, cast from/to a uintprt_t on the userspace side and
    from/to a void __user * in the kernel. Try really hard not to delay this
    conversion or worse, fiddle the raw __u64 through your code since that
    diminishes the checking tools like sparse can provide.

This doesn't seem like it will work on 32-bit systems since you'll end up
with the warning above. Is there a better option or did I misunderstand
how that is supposed to work?


I don't know a better way that two cast, doing
        
        (struct ion_heap_data __user *)(uintptr_t)query->heaps;

It may help to put this into an inline function though.

        Arnd


There already is one it turns out in kernel.h:

#define u64_to_user_ptr(x) (            \
{                                       \
        typecheck(u64, x);              \
        (void __user *)(uintptr_t)x;    \
}                                       \
)

At least this way I don't have to look at the double casts.

Thanks,
Laura


Reply via email to