From: Doug Oucharek <doug.s.oucha...@intel.com>

In lnet_rtrpools_enable(), a mistake was made and routing
was not being turned on when the rtrpools are being allocated
for the first time.

This patch fixes that routine so we remember to turn on
routing after allocating the rtrpools.

Signed-off-by: Doug Oucharek <doug.s.oucha...@intel.com>
Intel-bug-id: https://jira.hpdd.intel.com/browse/LU-8501
Reviewed-on: http://review.whamcloud.com/21934
Reviewed-by: James Simmons <uja.o...@yahoo.com>
Reviewed-by: Amir Shehata <amir.sheh...@intel.com>
Reviewed-by: Dmitry Eremin <dmitry.ere...@intel.com>
Reviewed-by: Oleg Drokin <oleg.dro...@intel.com>
Signed-off-by: James Simmons <jsimm...@infradead.org>
---
 drivers/staging/lustre/lnet/lnet/router.c |   10 +++++-----
 1 files changed, 5 insertions(+), 5 deletions(-)

diff --git a/drivers/staging/lustre/lnet/lnet/router.c 
b/drivers/staging/lustre/lnet/lnet/router.c
index 69819c9..063ad55 100644
--- a/drivers/staging/lustre/lnet/lnet/router.c
+++ b/drivers/staging/lustre/lnet/lnet/router.c
@@ -1693,7 +1693,7 @@ lnet_rtrpools_adjust(int tiny, int small, int large)
 int
 lnet_rtrpools_enable(void)
 {
-       int rc;
+       int rc = 0;
 
        if (the_lnet.ln_routing)
                return 0;
@@ -1706,9 +1706,9 @@ lnet_rtrpools_enable(void)
                 * if we are just configuring this for the first
                 * time.
                 */
-               return lnet_rtrpools_alloc(1);
-
-       rc = lnet_rtrpools_adjust_helper(0, 0, 0);
+               rc = lnet_rtrpools_alloc(1);
+       else
+               rc = lnet_rtrpools_adjust_helper(0, 0, 0);
        if (rc)
                return rc;
 
@@ -1718,7 +1718,7 @@ lnet_rtrpools_enable(void)
        the_lnet.ln_ping_info->pi_features &= ~LNET_PING_FEAT_RTE_DISABLED;
        lnet_net_unlock(LNET_LOCK_EX);
 
-       return 0;
+       return rc;
 }
 
 void
-- 
1.7.1

Reply via email to