Hi Russell,

Are you in a position to be able to test this now?

I believe it should work fine on anything since 4.8-rc1.
(specifically, either of commit e28cd4d0a223 or 79190ea2658a)

Thanks,
Brian

On Tue, Aug 09, 2016 at 11:48:12PM +0100, Russell King - ARM Linux wrote:
On Tue, Aug 09, 2016 at 08:07:24AM +0200, Daniel Vetter wrote:
On Mon, Aug 08, 2016 at 05:04:03PM +0100, Brian Starkey wrote:
> Hi,
>
> On Mon, Jul 25, 2016 at 05:08:21PM +0200, Daniel Vetter wrote:
> > On Mon, Jul 25, 2016 at 01:54:06PM +0100, Brian Starkey wrote:
> > > Hi Russell,
> > >
> > > On Mon, Jul 25, 2016 at 01:25:04PM +0100, Russell King - ARM Linux wrote:
> > > > On Mon, Jul 25, 2016 at 11:55:48AM +0100, Brian Starkey wrote:
> > > > > The connector shouldn't be registered until the rest of the whole 
device
> > > > > is set up, so that consistent state is presented to userspace.
> > > > >
> > > > > As drm_dev_register() now registers all of the connectors anyway,
> > > > > there's no need to explicitly do it in individual drivers so remove
> > > > > the calls to drm_connector_register()/drm_connector_unregister().
> > > > >
> > > > > This allows componentised drivers to use tda998x without having racy
> > > > > initialisation.
> > > >
> > > > Is there a corresponding patch for armada-drm so that the cubox doesn't
> > > > regress?  Has it already been merged?
> > > >
> > >
> > > A patch for armada-drm to do what?
> > >
> > > I should perhaps have explicitly mentioned that this change depends
> > > on e28cd4d0a223: "drm: Automatically register/unregister all
> > > connectors", which is in drm-next.
> > >
> > > Like my commit message says - after the above commit, all connectors
> > > are automatically registered in drm_dev_register() - so I don't
> > > anticipate any regression, but I don't have a cubox to test.
> > >
> > > armada-drm seems to be doing effectively the same thing as arm/hdlcd,
> > > which works fine after this patch with no other changes.
> > >
> > > Let me know if I've missed something; or if you are able to test on
> > > cubox that would be great.
> >
> > Ack from my side on generally nuking drm_connector_register() from
> > everywhere except truely hotplugged connectors like dp mst. It should keep
> > working for everyone. Only exception is if there's a driver which calls
> > drm_dev_register too early (before all connectors are probed), which would
> > be a bug anyway.
>
> Right; the motivation for this change is to fix the init order in
> HDLCD and Mali-DP (move drm_dev_register to the end), which we can't
> do right now because tda998x expects the DRM device sysfs to be set
> up in bind.
>
> @Daniel: Can I take this as your Acked-by?

Sure.

> Should this go in via Russell's tree?

I can also throw it into drm-misc, if Russell (or someone else) can
provide a tested-by for armada. Better safe than sorry ;-)

I can't provide a tested-by for armada yet, because testing it on
my cubox tree (v4.7) causes a failure.  It probably relies on some
change merged during the merge window.

-- RMK's Patch system: http://www.armlinux.org.uk/developer/patches/
FTTC broadband for 0.8mile line: currently at 9.6Mbps down 400kbps up
according to speedtest.net.

Reply via email to