sorry for the delay fixing that bug. I got occupied with other things
and didn't really got to the issue again, it is on my todo list as the
next item though and I hope I will be able to get a fix ready this
weekend. I think I might know where the issue is, but didn't confirm
it yet.

Again, sorry for the delay.

Karol

2016-08-19 22:46 GMT+02:00 Karol Herbst <karolher...@gmail.com>:
> Hi again,
>
> I was able to get a crash/freeze/something while unbinding/binding my
> nvidia gpu from nouveau.
>
> Guess that means something is odd. I will investigate this more over
> the weekend.
>
> 2016-08-19 17:35 GMT+02:00 Andy Shevchenko <andy.shevche...@gmail.com>:
>> On Fri, Aug 19, 2016 at 6:08 PM, karol herbst <karolher...@gmail.com> wrote:
>>> 2016-08-19 15:02 GMT+02:00 Andy Shevchenko <andy.shevche...@gmail.com>:
>>>> On Fri, Aug 19, 2016 at 1:35 PM, karol herbst <karolher...@gmail.com> 
>>>> wrote:
>>>>> is there any update on that issue I missed somehow? I really don't
>>>>> want to leave the mmiotracer in a state, where it breaks something
>>>>> while fixing other issues.
>>>>
>>>> No updates. I'm busy right now with more priority tasks and revert
>>>> works for me. Issue is reproducible in my case 100%.
>>>>
>>>
>>> Is there something I could do with a "normal" haswell desktop system
>>> to reproduce this issue?
>>
>> Try LPSS UART device(s)
>>
>>>
>>> I'll try to play around the next days a bit and maybe I find something
>>> that works out here as well. It seems to be related to
>>> unmapping-mapping cycles.
>>
>> That is the only thing I would think of.
>>
>>>
>>> Because if this only happens with the pwm-lpss driver,
>>
>> It has nothing to do with pwm-lpss since it's a HS UART and served by
>> intel-lpss driver.
>>
>>> it may be
>>> really troublesome to debug, because I don't really know the code that
>>> well to be sure where the issue might be.
>>>
>>>> So, I would able to attach dmesg in case it would be helpful.
>>>> Otherwise tell me exact instructions how to debug the issue.
>>>>
>>>> Here you are:
>>>> http://pastebin.com/raw/VfTZENt7
>>>>
>>>>> But for now, without being able to even reproduce the issue, I can't
>>>>> really do much, because the code in the current state looks sane to
>>>>> me. Maybe this case includes the mmiotracer cleaning things up and
>>>>> arms new region for mmiotracing and that's why it fails? Besides that,
>>>>> I have no idea and no way to reproduce this, so I can't help this way.
>>>>
>>>> Maybe. First thing happened is iounmap().
>>
>>
>> --
>> With Best Regards,
>> Andy Shevchenko

Reply via email to