> >                             addfield(map, &extra_desc, ". ",
> >                                     " Supports address when precise",
> >                                     NULL);
> > +                   } else if (json_streq(map, field, "Unit")) {
> so I remember you said you're preparing JSON events files for perf,
> so why not call this field "Pmu" directly? Would be less confusing
> wrt the ScaleUnit field

While I'm cleaning up the files somewhat, I'm still trying to be
compatible with the original format, so that it's also possible
to drop in unchanged files. Also it's better if there is only
one kind of JSON event format, not multiple subtle incompatible


Reply via email to