On Sun, Oct 16, 2016 at 03:29:14PM +0530, Pankaj Bharadiya wrote: > gb_audio_manager_module_descriptor's cport field is actually used to > manage and pass interface id to user space. > > Thus rename gb_audio_manager_module_descriptor's 'cport' field and > few other things to avoid confusion.
Please be more specific about what these other things are; in this case sysfs attributes, uevent vars, and an odd-looking sysfs-string interface (more?). Wouldn't this change break any current user-space implementation? Also why aren't any of these attributes documented as they should be? Thanks, Johan