On Tuesday, October 18, 2016 11:57:33 AM CEST Ilya Dryomov wrote:
> It already got silenced by initializing at declaration in one of the
> downstream trees, so I'd rather we do
> @@ -3756,7 +3819,7 @@ static void rbd_watch_cb(void *arg, u64
> notify_id, u64 cookie,
> struct rbd_device *rbd_dev = arg;
> void *p = data;
> void *const end = p + data_len;
> - u8 struct_v;
> + u8 struct_v = 0;
> u32 len;
> u32 notify_op;
> int ret;
> to reduce the churn.
Fair enough. I try to avoid adding extraneous initializations like
this, but my suggested change is not all that different here,
except if ceph_start_decoding() got changed in a way that could
lead to another uninitialized use.
> The "block" prefix is redundant and "rdb" should be "rbd" in the subject.