On 10-23-16, Borislav Petkov wrote:
> Now, I went and made it a bit more readable and put the commit IDs and
> their names on separate lines, like we do in tip:
> 
> "These macros were added in commit
> 
>   86a1c34a929f ("x86_64 syscall audit fast-path").
> 
> They were used for sycalls auditing, but this functionality was moved to
> the arch/x86/entry/common.c:syscall_trace_enter() in
> 
>   1f484aa69046 ("x86/entry: Move C entry and exit code to 
> arch/x86/entry/common.c")
> 
> syscall_trace_enter() now uses the same defines from <linux/audit.h>,
> so these defines are no longer used anywhere in entry_64.S and we may
> remove them."
>

Agree, this looks more readable. I will take into account this formatting.

> Also, we abbreviate git commits to 12 chars. What you could do is add
> this to your .gitconfig:
> 
> [alias]
>         one = show -s --pretty='format:%h (\"%s\")'
> 
> and then simply do
> 
> $ git one 1f484aa69
> 
> and it'll format it properly for ya.
> 
> Anyway, just a couple of things to pay attention to in the future.

Yes, thanks for this.

> With this, you can add
> 
> Reviewed-by: Borislav Petkov <[email protected]>
> 
> to your v3.

Thank you.

Reply via email to