Paulo Marques wrote:
I don't like this name much :(

We already have kallsyms_lookup and kallsyms_lookup_name. The name of this function should imply that it will print the formatted result into the buffer, not just lookup a symbol.

Maybe "__sprint_symbol", and change the interface to "__sprint_symbol(char *buffer, unsigned long addr)"?
I'm not sure I like the leading __. In the print_symbol case, I think the function
was given a leading __ so that code referencing print_symbol would use the
macro which formulates the call into __print_symbol. I don't mind sprint_symbol
though.  Since Andrew Morton included the patch, I'll defer to his judgment.
+static inline void lookup_symbol(unsigned long addr, char *buffer)
+{
+       return NULL;
+}
Returning NULL in a function returning "void" doesn't seem right :P
You're right.  This should just be a simple "return;".  My bad.  Good catch.
Since Andrew Morton has already included this patch, I'll let him
make this change if he sees fit.

Regards,

Bob Peterson
Red Hat Cluster Suite

-
To unsubscribe from this list: send the line "unsubscribe linux-kernel" in
the body of a message to [EMAIL PROTECTED]
More majordomo info at  http://vger.kernel.org/majordomo-info.html
Please read the FAQ at  http://www.tux.org/lkml/

Reply via email to