On Tue, Mar 20, 2007 at 06:08:10PM -0400, Rik van Riel wrote:
> -             "Active:       %8lu kB\n"
> -             "Inactive:     %8lu kB\n"
...
> +             "Active(anon):   %8lu kB\n"
> +             "Inactive(anon): %8lu kB\n"
> +             "Active(file):   %8lu kB\n"
> +             "Inactive(file): %8lu kB\n"

Potentially incompatible change. How about preserving the original
fields (by totalling), then adding the other fields in a second patch.

>                       if (!pagevec_add(&lru_pvec, page))
> -                             __pagevec_lru_add(&lru_pvec);
> +                             __pagevec_lru_add_file(&lru_pvec);

Wouldn't lru_file_add or file_lru_add be a better name? If the object
is a "file lru" then sticking "add" in the middle is a little ugly.

>       spin_lock_irq(&zone->lru_lock);
>       if (PageLRU(page) && !PageActive(page)) {
> -             del_page_from_inactive_list(zone, page);
> +     if (page_anon(page)) {
> +             del_page_from_inactive_anon_list(zone,page);
>               SetPageActive(page);
> -             add_page_to_active_list(zone, page);
> +             add_page_to_active_anon_list(zone, page);
> +     } else {
> +             del_page_from_inactive_file_list(zone, page);
> +             SetPageActive(page);
> +             add_page_to_active_file_list(zone, page);
> +     }
>               __count_vm_event(PGACTIVATE);
>       }

Missing a level of indentation.

-- 
Mathematics is the supreme nostalgia of our time.
-
To unsubscribe from this list: send the line "unsubscribe linux-kernel" in
the body of a message to [EMAIL PROTECTED]
More majordomo info at  http://vger.kernel.org/majordomo-info.html
Please read the FAQ at  http://www.tux.org/lkml/

Reply via email to