On Wed, 2017-04-12 at 00:08 +0200, Borislav Petkov wrote:
> On Tue, Mar 07, 2017 at 04:32:36PM -0800, Ricardo Neri wrote:
> > Section 2.2.1.2 of the Intel 64 and IA-32 Architectures Software
> > Developer's Manual volume 2A states that when a SIB byte is used and the
> > base of the SIB byte points to R/EBP (i.e., base = 5) and the mod part
> > of the ModRM byte is zero, the value of such register will not be used
> > as part of the address computation. To signal this, a -EDOM error is
> > returned to indicate callers that they should ignore the value.
> > 
> > Also, for this particular case, a displacement of 32-bits should follow
> > the SIB byte if the mod part of ModRM is equal to zero. The instruction
> > decoder ensures that this is the case.
> > 
> > Cc: Dave Hansen <dave.han...@linux.intel.com>
> > Cc: Adam Buchbinder <adam.buchbin...@gmail.com>
> > Cc: Colin Ian King <colin.k...@canonical.com>
> > Cc: Lorenzo Stoakes <lstoa...@gmail.com>
> > Cc: Qiaowei Ren <qiaowei....@intel.com>
> > Cc: Peter Zijlstra <pet...@infradead.org>
> > Cc: Nathan Howard <liverl...@gmail.com>
> > Cc: Adan Hawthorn <adanhawth...@gmail.com>
> > Cc: Joe Perches <j...@perches.com>
> > Cc: Ravi V. Shankar <ravi.v.shan...@intel.com>
> > Cc: x...@kernel.org
> > Signed-off-by: Ricardo Neri <ricardo.neri-calde...@linux.intel.com>
> > ---
> >  arch/x86/mm/mpx.c | 29 ++++++++++++++++++++++-------
> >  1 file changed, 22 insertions(+), 7 deletions(-)
> > 
> > diff --git a/arch/x86/mm/mpx.c b/arch/x86/mm/mpx.c
> > index d9e92d6..ef7eb67 100644
> > --- a/arch/x86/mm/mpx.c
> > +++ b/arch/x86/mm/mpx.c
> > @@ -121,6 +121,17 @@ static int get_reg_offset(struct insn *insn, struct 
> > pt_regs *regs,
> >  
> >     case REG_TYPE_BASE:
> >             regno = X86_SIB_BASE(insn->sib.value);
> > +           /*
> > +            * If mod is 0 and register R/EBP (regno=5) is indicated in the
> > +            * base part of the SIB byte,
> 
> you can simply say here: "if SIB.base == 5, the base of the
> register-indirect addressing is 0."

This is better wording. I will change it.
> 
> > the value of such register should
> > +            * not be used in the address computation. Also, a 32-bit
> 
> Not "Also" but "In this case, a 32-bit displacement..."

Will change.
> 
> > +            * displacement is expected in this case; the instruction
> > +            * decoder takes care of it. This is true for both R13 and
> > +            * R/EBP as REX.B will not be decoded.
> 
> You don't need that sentence as the only thing that matters is ModRM.mod
> being 0.

For the specific case of ModRM.mod being 0, I feel I need to clarify
that REX.B is not decoded and if SIB.base is %r13 the base is also 0.
This comment adds clarity because REX.X is decoded when determining
SIB.index.
> 
> > +            */
> > +           if (regno == 5 && X86_MODRM_MOD(insn->modrm.value) == 0)
> 
> The 0 test we normally do with the ! (also flip parts of if-condition):
> 
>               if (!X86_MODRM_MOD(insn->modrm.value) && regno == 5)

Will change it.
> 
> > +                   return -EDOM;
> > +
> >             if (X86_REX_B(insn->rex_prefix.value))
> >                     regno += 8;
> >             break;
> > @@ -161,16 +172,21 @@ static void __user *mpx_get_addr_ref(struct insn 
> > *insn, struct pt_regs *regs)
> >             eff_addr = regs_get_register(regs, addr_offset);
> >     } else {
> >             if (insn->sib.nbytes) {
> > +                   /*
> > +                    * Negative values in the base and index offset means
> > +                    * an error when decoding the SIB byte. Except -EDOM,
> > +                    * which means that the registers should not be used
> > +                    * in the address computation.
> > +                    */
> >                     base_offset = get_reg_offset(insn, regs, REG_TYPE_BASE);
> > -                   if (base_offset < 0)
> > +                   if (unlikely(base_offset == -EDOM))
> > +                           base = 0;
> > +                   else if (unlikely(base_offset < 0))
> 
> Bah, unlikely's in something which is not really a hot path. They only
> encumber readability, no need for them.

I will remove them.

Thanks and BR,
Ricardo

Reply via email to