On mer., 2017-08-09 at 09:18 -0700, Matt Roper wrote:
> On Mon, Jul 31, 2017 at 10:36:05AM +0200, Jean Delvare wrote:
> > Hi Matt, Mauro,
> > On Thu, 17 Mar 2016 15:18:20 +0100, Jean Delvare wrote:
> > >
> > > On Tue, 8 Mar 2016 10:32:37 -0800, Matt Roper wrote:
> > > >
> > > > A couple of the EDAC drivers have a nice memdev_dmi_entry structure for
> > > > decoding DMI memory device entries. Move the structure definition to
> > > > dmi.h so that it can be shared between those drivers and also other
> > > > parts of the kernel; the i915 graphics driver is going to need to use
> > > > this structure soon as well. As part of this move we rename the
> > > > structure s/memdev_dmi_entry/dmi_entry_memdev/ to ensure it has a proper
> > > > 'dmi' prefix.
> > > >
> > > > v2:
> > > > - Rename structure to dmi_entry_memdev. (Jean)
> > > > - Use __packed instead of __attribute__((__packed__)) for consistency
> > > > with the rest of the dmi.h header. (Jean)
> > >
> > > Looks better. (...)
> > What happened to this patch? I never received v3. Is it sill needed?
> We ended up going a different direction in the graphics driver and wound
> up not needing access to this structure. If there's still interest in
> the general refactoring here, let me know and I can incorporate your
> last feedback and respin a v3.
No, if you don't need it anymore I'll just drop it.
SUSE L3 Support