> +static unsigned int get_bio_pages(struct bio *bio)
> +{
> +     unsigned i;
> +     struct bio_vec *bv;
> +
> +     bio_for_each_segment_all(bv, bio, i)
> +             ;
> +
> +     return i;
> +}

s/get_bio_pages/bio_nr_pages/ ?

Also this seems like a useful helper for bio.h

Reply via email to