Hi Mark, On 19/07/17 17:01, Mark Rutland wrote:
+#define HWCAP_APIA (1 << 16)
Can you rename it to HWCAP_ARM64_APIA or HWCAP_ARM_APIA? When we use it in user space, at least in GDB, we usually do this, #ifndef HWCAP_APIA #define HWCAP_APIA (1 << 16) #endif However, the code use this macro can be compiled on !arm64 host. If HWCAP_APIA is defined on other !arm64 host and its value is not (1 << 16), the program "aarch64_hwcap & HWCAP_APIA ? XXX : XXX;" is wrong, and compiler doesn't complain. I notice that mips, mn10300, sparc, and s390 define their HWCAP this way, like HWCAP_SPARC_FLUSH, HWCAP_MIPS_R6, HWCAP_S390_DFP, etc. IMPORTANT NOTICE: The contents of this email and any attachments are confidential and may also be privileged. If you are not the intended recipient, please notify the sender immediately and do not disclose the contents to any other person, use it for any purpose, or store or copy the information in any medium. Thank you.