Peter Zijlstra <pet...@infradead.org> wrote:
> On Tue, Aug 01, 2017 at 05:08:15PM -0700, Nadav Amit wrote:
>> From: Minchan Kim <minc...@kernel.org>
>> This patch is a preparatory patch for solving race problems caused by
>> TLB batch. For that, we will increase/decrease TLB flush pending count
>> of mm_struct whenever tlb_[gather|finish]_mmu is called.
>> Before making it simple, this patch separates architecture specific
>> part and rename it to arch_tlb_[gather|finish]_mmu and generic part
>> just calls it.
> I absolutely hate this. We should unify this stuff, not diverge it
Agreed, but I don’t see how this patch makes the situation any worse.
I’ll review your other comments by tomorrow due to some personal