On Thu, Aug 10, 2017 at 12:48:12PM +0200, Miroslav Benes wrote:
> Now there is a sysfs attribute called "force", which provides two
> functionalities, "signal" and "force" (previously "unmark"). I haven't
> managed to come up with better names. Proposals are welcome. On the
> other hand I do not mind it much.
Now "force" has two meanings, which is a little confusing. What do you
think about just having two separate write-only sysfs flags?
echo 1 > /sys/kernel/livepatch/signal
echo 1 > /sys/kernel/livepatch/force
That way there's no ambiguity.