On Tue, 23 Jan 2018, Florian Fainelli wrote:
> bmips_smp_movevec() references the CKSEG1 constant, which is about to be
> updated in order to support processors that might enable eXtended
> KSEG0/1. In doing so, we will generate a reference to a function, which
> is obviously not permissible within assembly. Fortunately,
> bmips_smp_movevec() is only used on BMIPS4350 which does not support
> eXtended KSEG0/1.
Can you please avoid replacing the macro with a hardcoded magic number
though, so that it retains the high-level meaning?
Define another macro, say MIPS_ARCH_CKSEG1, and use it here instead, and
possibly elsewhere too. You could complement it with BMIPS_XKS01_CKSEG1
if necessary too (I haven't thoroughly looked through your patches).