On 02/23/2018 04:39 PM, Boris Ostrovsky wrote:
On 02/23/2018 01:37 AM, Oleksandr Andrushchenko wrote:
On 02/23/2018 12:23 AM, Boris Ostrovsky wrote:
On 02/21/2018 03:03 AM, Oleksandr Andrushchenko wrote:
+static struct xenbus_driver xen_driver = {
+    .ids = xen_drv_ids,
+    .probe = xen_drv_probe,
+    .remove = xen_drv_remove,
+    .otherend_changed = backend_on_changed,
What does "_on_" stand for?
Well, it is somewhat like a hint that this is called "on" event,
e.g. event when the other end state has changed, backend in this
case. It could be something like "backend_on_state_changed"
If you look at other xenbus_drivers none of the uses this so I think we
should stick to conventional naming. (and the same applies to other
backend_on_* routines).
ok, no problem. will rename to be aligned with other frontends


-boris

Reply via email to