> >> Also.. it would be good to start pushing for more consistency in the
> >> labels: I have these on the thinkpad:
> >>
> >> input5::scrolllock/   tpacpi::dock_status2/ tpacpi::unknown_led/
> >> mmc0::/               tpacpi:green:batt/    tpacpi::unknown_led2/
> >> phy0-led/             tpacpi:orange:batt/   tpacpi::unknown_led3/
> >> tpacpi::bay_active/   tpacpi::power/
> In effect it looks like we should drop devicename section from
> the LED class devicename pattern, label should describe only
> LED function and additional color property could be introduced,
> to be concatenated with LED function as a final LED class device
> name.

Well, the device name makes sense if the LED is not on the "main"

I do have "scrollock" led on internal keyboard, and scollock led on
USB keyboard... it is good to be able to tell  which is which.

But yes, IMO it makes sense to move from

"as4134::backlight" to "screen::backlight" or something, and have it
standard across the machines.

tpacpi:: is not useful prefix for a led name. mmc0:: and input5:: are
quite useful.

Similary, as5124::flash is not useful, but main_camera::flash or
video5::flash might be.

(english) http://www.livejournal.com/~pavelmachek
(cesky, pictures) 

Attachment: signature.asc
Description: Digital signature

Reply via email to