On Fri,  2 Mar 2018 16:04:26 +0800 "Huang, Ying" <ying.hu...@intel.com> wrote:

> From: Huang Ying <ying.hu...@intel.com>
> 
> >From commit 4b3ef9daa4fc ("mm/swap: split swap cache into 64MB
> trunks") on, after swapoff, the address_space associated with the swap
> device will be freed.  So page_mapping() users which may touch the
> address_space need some kind of mechanism to prevent the address_space
> from being freed during accessing.
> 
> The dcache flushing functions (flush_dcache_page(), etc) in
> architecture specific code may access the address_space of swap device
> for anonymous pages in swap cache via page_mapping() function.  But in
> some cases there are no mechanisms to prevent the swap device from
> being swapoff, for example,
> 
> CPU1                                  CPU2
> __get_user_pages()                    swapoff()
>   flush_dcache_page()
>     mapping = page_mapping()
>       ...                               exit_swap_address_space()
>       ...                                 kvfree(spaces)
>       mapping_mapped(mapping)
> 
> The address space may be accessed after being freed.
> 
> But from cachetlb.txt and Russell King, flush_dcache_page() only care
> about file cache pages, for anonymous pages, flush_anon_page() should
> be used.  The implementation of flush_dcache_page() in all
> architectures follows this too.  They will check whether
> page_mapping() is NULL and whether mapping_mapped() is true to
> determine whether to flush the dcache immediately.  And they will use
> interval tree (mapping->i_mmap) to find all user space mappings.
> While mapping_mapped() and mapping->i_mmap isn't used by anonymous
> pages in swap cache at all.
> 
> So, to fix the race between swapoff and flush dcache, __page_mapping()
> is add to return the address_space for file cache pages and NULL
> otherwise.  All page_mapping() invoking in flush dcache functions are
> replaced with __page_mapping().
> 
> The patch is only build tested, because I have no machine with
> architecture other than x86.
> 
> ...
>
> +/*
> + * For file cache pages, return the address_space, otherwise return NULL
> + */
> +struct address_space *__page_mapping(struct page *page)
> +{
> +     struct address_space *mapping;
> +
> +     page = compound_head(page);
> +
> +     /* This happens if someone calls flush_dcache_page on slab page */
> +     if (unlikely(PageSlab(page)))
> +             return NULL;
> +
> +     mapping = page->mapping;
> +     if ((unsigned long)mapping & PAGE_MAPPING_ANON)
> +             return NULL;
> +
> +     return (void *)((unsigned long)mapping & ~PAGE_MAPPING_FLAGS);
> +}
> +

I think page_mapping_file() would be a better name.

And do we really need to duplicate page_mapping()?  Could it be

struct address_space *page_mapping_file(struct page *page)
{
        if (PageSwapCache(page))
                return NULL;
        return page_mapping(page);
}

(We don't need to run compound_head() here, do we?)

Reply via email to