Hi Shreeya,

> I was just going through your patch for giving myself 
> a habit of reading patches.


> I see here that there are many comments which are necessary
> have also been removed.
> Jonathan told that some of the names do not explain
> much about the how registers are related to the orientation.
> So it is necessary for some comments to be there here.
> I saw your next patch too, in which you are changing some of the
> names for betterment, but again, that doesn't cover everything which
> was told by Jonathan.
> Here is the link to the patch where Jonathan had given detailed 
> description
> Just sharing this information so in case if Jonathan agrees with
> this then he will not have to explain it all again :)
> https://lkml.org/lkml/2018/3/3/104

Well, the naming of macros is debatable as Jonathan pointed out[1] and
the unusual/odd naming pointed to you was for rotation registers

#define ADIS16209_ROT_OUT_REG           0x10

I renamed the unusual/odd naming macros for eg



as it didn't look like a failure bit address for which I consulted Jonathan to 
he agreed. Also, *DIAG_STAT* seems like a good name since these status registers
are serving the purpose of diagnosing the device behavior. Again, GLOB_CMD 
for Global Command register for controlling the deivce operation such as
Fatory Reset, Software Reset, etc.

See, it is difficult to point the perfect names than the suitable ones!
And let's just leave these *bikeshedding* ;-)

Himanshu Jha

Reply via email to