On Mon, Mar 12, 2018 at 04:33:11PM -0700, Darren Hart wrote:
> On Mon, Mar 12, 2018 at 03:17:57PM -0700, Linus Torvalds wrote:
> > On Mon, Mar 12, 2018 at 3:07 PM, Dominik Brodowski
> > <li...@dominikbrodowski.net> wrote:
> > >
> > > I'm awfully sorry, but this patch doesn't solve the issue.
> > > CONFIG_ACPI_WMI=y was/is set, but still enabling CONFIG_DELL_SMBIOS_WMI=y
> > > causes a very-early crash of v4.16-rc5. In fact, so early that the normal
> > > boot messages never show up on the screen...
> > 
> > Hmm. My xps13 works fine, but it's the 9350 version so not the same machine.
> > 
> > But it does sound like that commit 25d47027e10 ("platform/x86:
> > dell-smbios: Link all dell-smbios-* modules together") should just be
> > reverted. It has clearly caused a lot more pain than it fixed.
> Unfortunately, yes. This will re-instate the race condition it "fixed".
> I'll work with Mario to fix this properly in 4.17, preferably in a way
> that we can apply to stable. Pending an "oops, nevermind, the patch
> works" from Dominik by tomorrow morning, I'll submit the pull request to
> revert dell-smbios changes back to and including 25d47027e10.
> Apologies for the noise on this one Linus, it got away from me.

Hi Linus,

OK, I think we've identified the ordering issues and I have a patch out
pending testing from Dominik (hopefully tonight). I'd like to hold off
one more day on reverting if you're OK with that.

At RC5, we're certainly further into the RC cycle than I want to see
these changes. So if you just want to call it now, I understand and I'll
send you the revert pull request. If you can give me another day, I
think we may finally have found the end of this loose string.


Darren Hart
VMware Open Source Technology Center

Reply via email to