On Fri, Apr 06, 2018 at 09:58:37AM +0200, Peter Zijlstra wrote:
> On Fri, Apr 06, 2018 at 04:44:14AM +0200, Frederic Weisbecker wrote:
> > You can move that to tick_sched_do_timer() to avoid code duplication.
> 
> I expect the reason I didn't was that it didn't have @ts, but that's
> easily fixable.
> 
> > Also these constants are very opaque. And even with proper symbols it 
> > wouldn't look
> > right to extend ts->inidle that way.
> > 
> > Perhaps you should add a field such as ts->got_idle_tick under the boolean 
> > fields
> > after the below patch:
> 
> > @@ -45,14 +45,17 @@ struct tick_sched {
> >     struct hrtimer                  sched_timer;
> >     unsigned long                   check_clocks;
> >     enum tick_nohz_mode             nohz_mode;
> > +
> > +   unsigned int                    inidle          : 1;
> > +   unsigned int                    tick_stopped    : 1;
> > +   unsigned int                    idle_active     : 1;
> > +   unsigned int                    do_timer_last   : 1;
> 
> That would generate worse code, but yes, the C might be prettier.

Well, not too bad I think. MOV become OR/AND, the rest is just
TESTs...

Reply via email to