On Mon, Apr 9, 2018 at 10:14 AM, Linus Torvalds
<torva...@linux-foundation.org> wrote:
> On Mon, Apr 9, 2018 at 10:03 AM, Linus Torvalds
> <torva...@linux-foundation.org> wrote:
>> Our old "min()" had the internal variables called "min1" and "min2",
>> which is crazy too.
> Actually, no, it used the really cumbersome "__UNIQUE_ID" and then
> passed that odd as the name 'min1/2',
> Ugh, I find that really nasty to read, but it was obviously done
> because we hit this before.

Ooof. Nice find.

> And our __UNIQUE_ID() macro is garbage anyway, since it falls back on
> the line number, which doesn't really work for macros anyway. But we
> have proper macros for both clang and gcc, so maybe we should ignore
> the broken fallback.
> A patch like the attached, perhaps?

Can we update the comment near the top to explain why we need
__UNIQUE_ID() since we've now rediscovered why it was originally


Kees Cook
Pixel Security

Reply via email to