4.15-stable review patch.  If anyone has any objections, please let me know.

------------------

From: Archit Taneja <arch...@codeaurora.org>


[ Upstream commit 9dcfbc182f1aac0aa5ea194733d21e67dd2ba1fd ]

The msm/kms driver should work even if there is no GPU device specified
in DT. Currently, we get a NULL dereference crash in adreno_load_gpu
since the driver assumes that priv->gpu_pdev is non-NULL.

Perform an additional check on priv->gpu_pdev before trying to retrieve
the msm_gpu pointer from it.

v2: Incorporate Jordan's comments:
- Simplify the check to share the same error message.
- Use dev_err_once() to avoid an error message every time we open the
  drm device fd.

Fixes: eec874ce5ff1 (drm/msm/adreno: load gpu at probe/bind time)

Signed-off-by: Archit Taneja <arch...@codeaurora.org>
Acked-by: Jordan Crouse <jcro...@codeaurora.org>
Signed-off-by: Rob Clark <robdcl...@gmail.com>
Signed-off-by: Sasha Levin <alexander.le...@microsoft.com>
Signed-off-by: Greg Kroah-Hartman <gre...@linuxfoundation.org>
---
 drivers/gpu/drm/msm/adreno/adreno_device.c |    7 +++++--
 1 file changed, 5 insertions(+), 2 deletions(-)

--- a/drivers/gpu/drm/msm/adreno/adreno_device.c
+++ b/drivers/gpu/drm/msm/adreno/adreno_device.c
@@ -125,11 +125,14 @@ struct msm_gpu *adreno_load_gpu(struct d
 {
        struct msm_drm_private *priv = dev->dev_private;
        struct platform_device *pdev = priv->gpu_pdev;
-       struct msm_gpu *gpu = platform_get_drvdata(priv->gpu_pdev);
+       struct msm_gpu *gpu = NULL;
        int ret;
 
+       if (pdev)
+               gpu = platform_get_drvdata(pdev);
+
        if (!gpu) {
-               dev_err(dev->dev, "no adreno device\n");
+               dev_err_once(dev->dev, "no GPU device was found\n");
                return NULL;
        }
 


Reply via email to