On 11-04-18, 15:39, Patrick Bellasi wrote:
> On 11-Apr 12:58, Peter Zijlstra wrote:
> > On Wed, Apr 11, 2018 at 11:44:45AM +0100, Patrick Bellasi wrote:
> > > > > - sugov_set_iowait_boost: is now in charge only to set/increase the IO
> > > > >      wait boost, every time a task wakes up from an IO wait.
> > > > > 
> > > > > - sugov_iowait_boost: is now in charge to reset/reduce the IO wait
> > > > >      boost, every time a sugov update is triggered, as well as
> > > > >      to (eventually) enforce the currently required IO boost value.
> > > > 
> > > > I'm not sold on those function names; feels like we can do better,
> > > > although I'm struggling to come up with anything sensible just now.
> > > 
> > > What about something like:
> > > 
> > >  sugov_iowait_init()
> > >  since here we are mainly initializing the iowait boost
> > > 
> > >  sugov_iowait_boost()
> > >  since here we are mainly applying the proper boost to each cpu
> > > 
> > > Although they are not really so different...
> > 
> > How about:
> > 
> >   sugov_iowait_boost() -- does the actual impulse/boost
> >   sugov_iowait_apply() -- applies the boost state
> > 
> > ?
> 
> Whould say it can work too, and it also allows to add a:
> 
>     sugov_iowait_reset() -- resets boots state after
>                             TICK_NSEC CPU idle time
> 
> Viresh, Rafael, Joel: any preferences or other suggestions?

Looks like no matter how we rename it, someone will find it confusing
:)

-- 
viresh

Reply via email to