On 15/04/2018 14:09, Fabio Estevam wrote:
> Hi Gustavo,
> On Wed, Apr 11, 2018 at 4:40 AM, Gustavo Pimentel
> <gustavo.pimen...@synopsys.com> wrote:
>> Can be this one?
>> Probably any recent and decent compiler does this kind of substitution
>> in order to improve code performance. Nevertheless it's a coding good
>> practice whenever there is a division / multiplication by multiple of 2
>> to replace it by the equivalent operation in this case, the shift
> Subject says that this patch provides a computation improvement, but
> as you said above the compiler
> will perform the shift, so it doesn't seem we will get any benefit.
In the worth case there is no performance, so it will not hurt having it.
However depending the compiler and the platform this can bring some improvement.
For instance like Jingoo said: "The most platforms using 'dwc' are based on ARM
CPUs. So, the shift rotation can be better."
It's just a attempt to improve the code that doesn't bring any harm.
> IMHO the original code has better readability as it makes easier to
> understand that pp->cfg0_size will get the half of
> resource_size(pp->cfg) size.
Personally I prefer the shift rotation rather the division by 2. But in my case
I'm used to use/see this type of operation, but it's like I said it's my
> I would say it is better to drop this patch from the series.
Let's see this patch inflicts pain on someone else, in that case I'll remove
from the series.