On Fri, 10 Aug 2018 11:21:37 +0200
Jiri Olsa <jo...@redhat.com> wrote:
> > This is not complete. It is only one of many preparations to make
> > libtraceevent into a legitimate library. There's other naming conventions
> > that will be made. But for now, I would like to hear thoughts about
> > this change before we proceed further.
> right, I can see more things that needs rename, like in print_arg*,
> trace_* stuff and others
We are working on renaming the other data structures. As for the
"trace_" it is really "trace_seq_*" That's not going to get renamed. We
may move it to another header file. It matches the trace_seq_* code in
the kernel, and I would like to keep that the same.
> I'm also getting weird make error when compiling in libtraceevent dir:
> [jolsa@krava traceevent]$ make
> GEN libtraceevent-dynamic-list
> Either missing one of [ plugin_jbd2.so plugin_hrtimer.so plugin_kmem.so
> plugin_kvm.so plugin_mac80211.so plugin_sched_switch.so plugin_function.so
> plugin_xen.so plugin_scsi.so plugin_cfg80211.so] or bad version of nm
> but that seems to be there even without your patchset,
> so probably something we should look into
Hmm, OK, I'll try to look into that later.
> other than that it looks ok to me
> once this is done, we can move forward to put this
> to kernel-tools-libs-devel rpm
For this patch series, do you want to take the patch set, or just pull
from my branch?