On Sun, Nov 25, 2018 at 07:33:41PM +0100, Thomas Gleixner wrote:
> Reorder the code so it is better grouped.
> 
> Signed-off-by: Thomas Gleixner <t...@linutronix.de>
> 
> ---
>  arch/x86/kernel/cpu/bugs.c |  168 
> ++++++++++++++++++++++-----------------------
>  1 file changed, 84 insertions(+), 84 deletions(-)

...

>  static const struct {
>       const char *option;
>       enum spectre_v2_mitigation_cmd cmd;
>       bool secure;
>  } mitigation_options[] = {

Yeah, now that we have ssb_mitigation_options and v2_user_options also,
those should probably be called "spectre_v2_options" or something more
specific to have the code more clear which options the code is using...


> -     { "off",               SPECTRE_V2_CMD_NONE,              false },
> -     { "on",                SPECTRE_V2_CMD_FORCE,             true },
> -     { "retpoline",         SPECTRE_V2_CMD_RETPOLINE,         false },
> -     { "retpoline,amd",     SPECTRE_V2_CMD_RETPOLINE_AMD,     false },
> -     { "retpoline,generic", SPECTRE_V2_CMD_RETPOLINE_GENERIC, false },
> -     { "auto",              SPECTRE_V2_CMD_AUTO,              false },
> +     { "off",                SPECTRE_V2_CMD_NONE,              false },
> +     { "on",                 SPECTRE_V2_CMD_FORCE,             true  },
> +     { "retpoline",          SPECTRE_V2_CMD_RETPOLINE,         false },
> +     { "retpoline,amd",      SPECTRE_V2_CMD_RETPOLINE_AMD,     false },
> +     { "retpoline,generic",  SPECTRE_V2_CMD_RETPOLINE_GENERIC, false },
> +     { "auto",               SPECTRE_V2_CMD_AUTO,              false },
>  };

-- 
Regards/Gruss,
    Boris.

Good mailing practices for 400: avoid top-posting and trim the reply.

Reply via email to