On Thu, Nov 29, 2018 at 10:44:21AM +0100, Petr Mladek wrote:
> The address of the to be patched function and new function is stored
> in struct klp_func as:
> 
>       void *new_func;
>       unsigned long old_addr;
> 
> The different naming scheme and type is derived from the way how
                                                       ^^^^^^^^^^^
s/the way how/the way

> the addresses are set. @old_addr is assigned at runtime using
> kallsyms-based search. @new_func is statically initialized,
> for example:
> 
>   static struct klp_func funcs[] = {
>       {
>               .old_name = "cmdline_proc_show",
>               .new_func = livepatch_cmdline_proc_show,
>       }, { }
>   };
> 
> This patch changes unsigned log old_addr -> void *old_func. It removes
                     ^^^^^^^^^^^^
s/unsigned log/unsigned long

> some confusion when these address are later used in the code. It is
> motivated by a followup patch that adds special NOP struct klp_func
> where we want to assign func->new_func = func->old_addr respectively
> func->new_func = func->old_func.
> 
> This patch does not modify the existing behavior.
> 
> Suggested-by: Josh Poimboeuf <jpoim...@redhat.com>
> Signed-off-by: Petr Mladek <pmla...@suse.com>
> ---

Acked-by: Joe Lawrence <joe.lawre...@redhat.com>

-- Joe

Reply via email to