On Mon, May 27, 2019 at 10:31:59AM +0300, Dan Carpenter wrote:
> On Fri, May 24, 2019 at 01:08:01PM +0200, Simon Sandström wrote:
> > [..]
> > -           ret = copy_to_user((void*)ioctl_param, (void*)&temp, 
> > sizeof(temp));
> > +           ret = copy_to_user((void *)ioctl_param, (void *)&temp, 
> > sizeof(temp));
> >             if (ret)
> >                     return -EFAULT;
> 
> This should really be written like so:
> 
>               if (copy_to_user((void __user *)ioctl_param, &temp,
>                                sizeof(temp)))
>                       return -EFAULT;
> 
> temp is really the wrong name.  "temp" is for temperatures.  "tmp" means
> temporary.  But also "tmp" is wrong here because it's not a temporary
> variable.  It's better to call it "regs" here.
> 
> regards,
> dan carpenter
> 

I agree, but I don't think it fits within this patch. I can send a
separate patch with this change.

Thanks

- Simon

Reply via email to