On Thu, May 21, 2020 at 03:52:23PM -0500, Tyler Hicks wrote:
> Undefine parse_u32, instead of parse_size, as the name of the macro
> recently changed but the #undef directive wasn't updated at that time.
> 
> Fixes: 6b31e99b85b0 ("pstore/ram: Refactor DT size parsing")
> Signed-off-by: Tyler Hicks <[email protected]>
> ---
> 
> Hi Kees - Here's a minor fixup that I noticed was needed while reviewing
> your for-next/pstore branch. It is only build-tested but I think that's
> all that's needed here.

Whoops! Thanks; applied!

-Kees

> 
> Tyler
> 
>  fs/pstore/ram.c | 2 +-
>  1 file changed, 1 insertion(+), 1 deletion(-)
> 
> diff --git a/fs/pstore/ram.c b/fs/pstore/ram.c
> index df8965817c7b..ca6d8a867285 100644
> --- a/fs/pstore/ram.c
> +++ b/fs/pstore/ram.c
> @@ -674,7 +674,7 @@ static int ramoops_parse_dt(struct platform_device *pdev,
>       parse_u32("flags", pdata->flags, 0);
>       parse_u32("max-reason", pdata->max_reason, pdata->max_reason);
>  
> -#undef parse_size
> +#undef parse_u32
>  
>       /*
>        * Some old Chromebooks relied on the kernel setting the
> -- 
> 2.25.1
> 

-- 
Kees Cook

Reply via email to