Hi Andy,

Thank you so much for the review comments...

On 11/6/2020 4:12 pm, Andy Shevchenko wrote:
On Thu, Jun 11, 2020 at 10:12:46AM +0800, Ramuthevar,Vadivel MuruganX wrote:
From: Ramuthevar Vadivel Murugan <vadivel.muruganx.ramuthe...@linux.intel.com>

Add support for USB PHY on Intel LGM SoC.

...

+static int get_flipped(struct tca_apb *ta, bool *flipped)
+{
+       union extcon_property_value property;
+       int ret;
+
+       ret = extcon_get_property(ta->phy.edev, EXTCON_USB_HOST,
+                                 EXTCON_PROP_USB_TYPEC_POLARITY, &property);
+       if (ret) {
+               dev_err(ta->phy.dev, "no polarity property from extcon\n");

+               return false;

return ret;
Noted.

+       }
+
+       *flipped = property.intval;
+

+       return *flipped;

return 0;
Noted.

+}

...I suppose it should be as above.

...

+       ret = readl_poll_timeout(ctrl1, val, val & SRAM_INIT_DONE,
+                                10, 10 * 1000);
exceeds more than 80 characters, so checkpatch throws warnings, to avoid that move to next line.

On one line easier to read.

+       if (ret) {
+               dev_err(ta->phy.dev, "SRAM init failed, 0x%x\n", val);
+               return ret;
+       }

...

+static int phy_set_vbus(struct usb_phy *phy, int on)
+{
+       struct tca_apb *ta = container_of(phy, struct tca_apb, phy);

+       int ret = 0;

Assignment is redundant.
so you mean , should be declared as
int ret;
right?


+
+       if (on) {
+               ret = regulator_enable(ta->vbus);
+               if (ret)
+                       dev_err(ta->phy.dev, "regulator not enabled\n");
+       } else {
+               ret = regulator_disable(ta->vbus);
+               if (ret)
+                       dev_err(ta->phy.dev, "regulator not disabled\n");
+       }
+
+       return ret;
+}

...

+       ret = get_flipped(ta, &flipped);
+       if (!ret)
+               dev_err(ta->phy.dev, "no polarity property from extcon\n");

This should be fixed accordingly.
Noted.

...

+               dev_info(ta->phy.dev, "connected%s\n",
+                        flipped ? " flipped" : "");

One line.
exceeds more than 80 characters, so checkpatch throw warnings, to avoid that moved to next line.

Regards
Vadivel

Reply via email to