* Sam Ravnborg ([EMAIL PROTECTED]) wrote:
> Hi Mathieu.
> 
> > 
> > It would be much better to do
> > 
> >         depends on ARCH_SUPPORTS_KPROBES
> > 
> > in that generic file, and then architectures that do support it would just
> > have a
> > 
> >         bool ARCH_SUPPORTS_KPROBES
> >                 default y
> 
> The above suggestion is actually not exactly the best way to do it...
> First the naming..
> A quick grep shows following usage today (in Kconfig files)
> ARCH_HAS      51
> ARCH_SUPPORTS 4
> HAVE_ARCH     7
> 
> ARCH_HAS is the clear winner.
> 
> 
> In the common Kconfig file do:
> 
> config FOO
>       depends on ARCH_HAS_FOO
>       bool "bla bla" 
> 
> config ARCH_HAS_FOO
>       def_bool n
> 
> 
> In the arch specific Kconfig file in a suitable place do:
> 
> config SUITABLE_OPTION

Since config KPROBES will already be used in the architecture
independent Kconfig, I should find a different name for "config
SUITABLE_OPTION". Would

config KPROBES_SUPPORT
  select ARCH_HAS_KPROBES

be ok ?

>       select ARCH_HAS_FOO
> 
> 
> The naming of ARCH_HAS_ is fixed and shall be:
> ARCH_HAS_<config option it will enable>
> 
> 
> Only a single line added pr. architecture.
> And we will end up with a (maybe even commented) list of trivial selects.
> 
> Sorry for providing late feedback on this!
> 
>       Sam

-- 
Mathieu Desnoyers
Computer Engineering Ph.D. Student, Ecole Polytechnique de Montreal
OpenPGP key fingerprint: 8CD5 52C3 8E3C 4140 715F  BA06 3F25 A8FE 3BAE 9A68
-
To unsubscribe from this list: send the line "unsubscribe linux-kernel" in
the body of a message to [EMAIL PROTECTED]
More majordomo info at  http://vger.kernel.org/majordomo-info.html
Please read the FAQ at  http://www.tux.org/lkml/

Reply via email to