On Fri 11-09-20 15:48:29, Laurent Dufour wrote:
> The memmap_context is used to detect whether a memory operation is due to a
> hot-add operation or happening at boot time.
> 
> Makes it general to the hotplug operation, renaming it at memplug_context
> and move its define in the corresponding header.
> 
> There is no functional change introduced by this patch

I do not want to nit picking on naming but we want to look at this from
the initialization POV rather than hotplug. So....
> 
> Suggested-by: David Hildenbrand <da...@redhat.com>
> Signed-off-by: Laurent Dufour <lduf...@linux.ibm.com>
[...]
> diff --git a/include/linux/memory_hotplug.h b/include/linux/memory_hotplug.h
> index 375515803cd8..cd2bd21d3a4d 100644
> --- a/include/linux/memory_hotplug.h
> +++ b/include/linux/memory_hotplug.h
> @@ -15,6 +15,15 @@ struct memory_block;
>  struct resource;
>  struct vmem_altmap;
>  
> +/*
> + * Memory plugin context, use to differentiate memory added at boot time and
> + * hot-plugged memory.
> + */
> +enum memplug_context {
> +     MEMPLUG_EARLY,
> +     MEMPLUG_HOTPLUG,
> +};

/*
 * Memory initialization context, use to differentiate memory added by
 * the platform statically or via memory hotplug interface.
 */
enum meminit_context {
        MEMINIT_EARLY,
        MEMINIT_HOTPLUG
}

-- 
Michal Hocko
SUSE Labs

Reply via email to