The following commit has been merged into the core/rcu branch of tip:

Commit-ID:     c386e29d43728778ddd642fa73cc582bee684171
Gitweb:        
https://git.kernel.org/tip/c386e29d43728778ddd642fa73cc582bee684171
Author:        Hui Su <sh_...@163.com>
AuthorDate:    Thu, 15 Oct 2020 22:13:34 +08:00
Committer:     Paul E. McKenney <paul...@kernel.org>
CommitterDate: Fri, 06 Nov 2020 17:02:43 -08:00

docs/rcu: Update the call_rcu() API

This commit updates the documented API of call_rcu() to use the
rcu_callback_t typedef instead of the open-coded function definition.

Signed-off-by: Hui Su <sh_...@163.com>
Signed-off-by: Paul E. McKenney <paul...@kernel.org>
---
 Documentation/RCU/whatisRCU.rst | 3 +--
 1 file changed, 1 insertion(+), 2 deletions(-)

diff --git a/Documentation/RCU/whatisRCU.rst b/Documentation/RCU/whatisRCU.rst
index fb3ff76..1a4723f 100644
--- a/Documentation/RCU/whatisRCU.rst
+++ b/Documentation/RCU/whatisRCU.rst
@@ -497,8 +497,7 @@ long -- there might be other high-priority work to be done.
 In such cases, one uses call_rcu() rather than synchronize_rcu().
 The call_rcu() API is as follows::
 
-       void call_rcu(struct rcu_head * head,
-                     void (*func)(struct rcu_head *head));
+       void call_rcu(struct rcu_head *head, rcu_callback_t func);
 
 This function invokes func(head) after a grace period has elapsed.
 This invocation might happen from either softirq or process context,

Reply via email to