On Fri, Jan 15, 2021 at 11:03 PM Saravana Kannan <sarava...@google.com> wrote:
>
> There are multiple instances of GPIO devictree nodes of the form:

What? Device Tree (or device tree).

> foo {
>         compatible = "acme,foo";
>         ...
>
>         gpio0: gpio0@xxxxxxxx {
>                 compatible = "acme,bar";
>                 ...
>                 gpio-controller;
>         };
>
>         gpio1: gpio1@xxxxxxxx {
>                 compatible = "acme,bar";
>                 ...
>                 gpio-controller;
>         };
>
>         ...
> }
>
> bazz {
>         my-gpios = <&gpio0 ...>;
> }
>
> Case 1: The driver for "foo" populates struct device for these gpio*
> nodes and then probes them using a driver that binds with "acme,bar".
> This lines up with how DT nodes with the "compatible" property are
> generally converted to struct devices and then registered with driver
> core to probe them. This also allows the gpio* devices to hook into all
> the driver core capabilities like runtime PM, probe deferral,
> suspend/resume ordering, device links, etc.
>
> Case 2: The driver for "foo" doesn't populate its child device nodes
> with "compatible" property and instead just loops through its child
> nodes and directly registers the GPIOs with gpiolib without ever
> populating a struct device or binding a driver to it.
>
> Drivers that follow the case 2 cause problems with fw_devlink=on.  This

follow case

> is because fw_devlink will prevent bazz from probing until there's a
> struct device that has gpio0 as its fwnode (because bazz lists gpio0 as
> a GPIO supplier). Once the struct device is available, fw_devlink will
> create a device link between with gpio0 as the supplier and bazz as the
> consumer. After this point, the device link will prevent bazz from
> probing until its supplier (the gpio0 device) has bound to a driver.
> Once the supplier is bound to a driver, the probe of bazz is triggered
> automatically.
>
> Finding and refactoring all the instances of drivers that follow case 2
> will cause a lot of code churn and it not something that can be done in

it is not

> one shot. Examples of such instances are [1] [2].
>
> This patch works around this problem and avoids all the code churn by
> simply creating a stub driver to bind to the gpio_device. Since the
> gpio_device already points to the GPIO device tree node, this allows all
> the consumers to continue probing when the driver follows case 2.
>
> If/when all the old drivers are refactored, we can revert this patch.
>
> [1] - https://lore.kernel.org/lkml/20201014191235.7f71fcb4@xhacker.debian/
> [2] - 
> https://lore.kernel.org/lkml/e28e1f38d87c12a3c714a6573beba...@kernel.org/

Link: tags?

...

> +       of_node = gdev->dev.of_node;

This seems unused (see below).

> +       fwnode = of_fwnode_handle(of_node);

I don't get this. Are you telling that dev_fwnode(&gdev->dev) is not the same?

> +       fwnode_dev = get_dev_from_fwnode(fwnode);
> +
> +       /*
> +        * If your driver hits this warning, it's because you are directly
> +        * parsing a device tree node with "compatible" property and
> +        * initializing it instead of using the standard DT + device driver
> +        * model of creating a struct device and then initializing it in the
> +        * probe function. Please refactor your driver.
> +        */

> +       if (!fwnode_dev && of_find_property(gdev->dev.of_node, "compatible")) 
> {

fwnode_property_present() ?

> +               chip_warn(gc, "Create a real device for %pOF\n" of_node);

%pfw ?

> +               gdev->dev.fwnode = fwnode;

Why not dev_fwnode()?

> +       }
>  #endif

...

> +static struct device_driver gpio_drv = {
> +       .name = "gpio_drv",

Can it have a better name, please?

> +       .bus = &gpio_bus_type,
> +       .probe = gpio_drv_probe,
> +};

-- 
With Best Regards,
Andy Shevchenko

Reply via email to