Matt Mackall wrote:

I hate the do_foo naming scheme (how about __warn_on?), but otherwise:

Acked-by: Matt Mackall <[EMAIL PROTECTED]>

after I moved it around based on Olof's work, I've now ended up with

warn_on_slowpath()


+               printk(KERN_WARNING "WARNING: at %s:%d %s()\n",
+                       __FILE__, __LINE__, __FUNCTION__);
+               dump_stack();

While we're here, I'll mention that dump_stack probably ought to take a
severity level argument.

125 files changed, 202 insertions(+), 199 deletions(-)
just to get the api change done.
I can hear akpm cringe from here...



--
To unsubscribe from this list: send the line "unsubscribe linux-kernel" in
the body of a message to [EMAIL PROTECTED]
More majordomo info at  http://vger.kernel.org/majordomo-info.html
Please read the FAQ at  http://www.tux.org/lkml/

Reply via email to