On Fri, Mar 26, 2021 at 3:38 PM Christoph Hellwig <[email protected]> wrote: > > Remove the duplicated copying of the pathname into the common helper. > > Signed-off-by: Christoph Hellwig <[email protected]>
Looks correct, but > -static int do_execveat(int fd, struct filename *filename, > +static int do_execveat(int fd, const char __user *pathname, > const char __user *const __user *argv, > const char __user *const __user *envp, int flags) Maybe rename this to ksys_execveat() for consistency now? I think that is the current trend for functions that are essentially just the syscall. With or without that change Reviewed-by: Arnd Bergmann <[email protected]>

