This patch improves the clarity and grammar of output messages in the acct()
selftest. Minor changes were made to user-facing strings and comments to make
them easier to understand and more consistent with the kselftest style.

Changes include:
- Fixing grammar in printed messages and comments.
- Rewording error and success outputs for clarity and professionalism.
- Making the "root check" message more direct.

These updates improve readability without affecting test logic or behavior.

Signed-off-by: Abdelrahman Fekry <abdelrahmanfekry...@gmail.com>
---
 tools/testing/selftests/acct/acct_syscall.c | 6 +++---
 1 file changed, 3 insertions(+), 3 deletions(-)

diff --git a/tools/testing/selftests/acct/acct_syscall.c 
b/tools/testing/selftests/acct/acct_syscall.c
index 87c044fb9293..2c120a527574 100644
--- a/tools/testing/selftests/acct/acct_syscall.c
+++ b/tools/testing/selftests/acct/acct_syscall.c
@@ -22,9 +22,9 @@ int main(void)
        ksft_print_header();
        ksft_set_plan(1);
 
-       // Check if test is run a root
+       // Check if test is run as root
        if (geteuid()) {
-               ksft_exit_skip("This test needs root to run!\n");
+               ksft_exit_skip("This test must be run as root!\n");
                return 1;
        }
 
@@ -52,7 +52,7 @@ int main(void)
        child_pid = fork();
 
        if (child_pid < 0) {
-               ksft_test_result_error("Creating a child process to log 
failed\n");
+               ksft_test_result_error("Failed to create child process for 
logging\n");
                acct(NULL);
                return 1;
        } else if (child_pid > 0) {
-- 
2.25.1


Reply via email to